Your best friend for file transfer.

Fetch application logoFetch

Can't Upload to Windows servers (2 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 22 years ago by dmolanphy
  • Latest reply 22 years ago from Jim Matthews
  • dmolanphy Member

    Okay, I hope I can explain this one:
    I am having problems uploading to any windows server from my mac. I have read all forums I can think of and nothing quite answers my questions: so here it goes:

    I am able to connect to the servers without any problem, although sometimes it takes FOREVER to get the file list, but it still runs just fine. I can download from the server just fine as well. I can also rename, move, change directories, etc. Only thing I can't do is upload. Every time I try to upload a file, it will stop at 32k, and then the transfer speed will progressively decrease and the program (fetch) basically "hangs". I have tried doing the passive FTP thing on both Internet Config as well as Fetch. I have also tried the new beta version of fetch, along with other programs including the OS X terminal, but the result is exactly the same! The only reason why I decided it's only happening with Windows servers is because I can upload to an Apache server just fine! And if I try uploading from Virtual PC it works fine too.
    The craziest part of it is that this is somewhat of a recent problem. I have been able to upload to these servers before without any problems, however lately, I can't upload squat. Yes, I'm behind a firewall, but like I said, I've been able to upload before and nothing on the firewall has changed from then to now. Is there anyone having any similar problems that can help me out? I would really appreciate it.! Thanks.

    Posted 22 years ago #

  • Jim Matthews Administrator

    When there's a problem with uploading (and not downloading) my first suspicion is a problem with network flow control. Some network devices (such as modems, including DSL and cable modems) can have problems when they are asked to send a bunch of data. The fix is usually to update the firmware or configuration of the device.

    The strange thing about your situation is that the problem is specific to certain servers, where I'd expect it to affect any server on the far side of the device in question. And it's strange that uploads under Virtual PC work, although that could be because emulated software will run slower, and not send data out as fast.

    So I'd recommend trying to upload to non-Windows servers on the same network as the Windows ones that are showing you the problem. That should help determine whether the fault is in a network device between your Mac and the servers or in the servers.

    Jim Matthews
    Fetch Softworks

    Posted 22 years ago #

Topic closed

This topic has been closed.