Your best friend for file transfer.

Fetch application logoFetch

Could not determine cwdir: Permission denied. (log included) (3 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 15 years ago by gsprague
  • Latest reply 15 years ago from Jim Matthews
  • gsprague Member

    OK, I am not a Fetch newbie, I've been using it sucessfully and have been quite happy. However 3 weeks ago my ISP was crashed by an electrical storm and since it came back up I get the following error when I try to upload.

    "Server response: Could not determine cwdir: Permission denied."

    Now the people at my ISP support center are generally total idiots and when it comes to anything Mac related they are World Class Total Idiots. I've reported the problem and get the "things are fine at our end response" which is no help at all. When I try to explain that nothing has changed on my end they suggest that I try an other FTP client. (Now why would Fetch work fine before the crash and not now?????) So I download the latest version of Fetch and get the same error and download Anarchie (ick) and still get the same error.

    Does anybody have anything I can tell these pseudo-support people to enlighten them (though I'm not sure they are open to enlightment). Or if it is on my end, what do I to fix it. Below is the log for a failed PUT attempt.


    Connecting to port 21 (5/26/02 9:29:00 PM)
    220 FTP server (Version wu-2.4.2-academ[BETA-13](3) Fri Jan 22 23:47:54 CST 1999) ready.
    USER gsprague
    331 Password required for gsprague.
    230 User gsprague logged in.
    215 UNIX Type: L8
    257 "." is current directory.
    CWD /home/g/gsprague/.html
    250 CWD command successful.
    257 "." is current directory.
    PORT 209,90,4,68,53,184
    200 PORT command successful.
    STOR answers.html
    553 Could not determine cwdir: Permission denied.
    ftp_store_setup: -30000
    221 You could at least say goodbye.

    Posted 15 years ago #

  • Jim Matthews Administrator

    I would suggest showing them the transcript. The answer to the PWD (print working directory" command shows that the server is messed up -- it should be the path to your home directory, not ".". This has nothing to do with whether you are using a Mac -- you would see the same thing connecting to your account from a Windows FTP client.

    My best guess is that the file that specifies the home directory for your account has been corrupted, but that's just a guess.

    Jim Matthews
    Fetch Softworks

    Posted 15 years ago #

  • Jim Matthews Administrator

    please ignore

    Posted 15 years ago #

Topic closed

This topic has been closed.