Your best friend for file transfer.

Fetch application logoFetch

Error: The server dropped the connection (5 posts)

  • Started 18 years ago by mac
  • Latest reply 18 years ago from Scott McGuire
  • mac Member

    Please help. I am using Fetch FTP 4.0.2 on Mac OS 10.4.2.

    When I try to connect I get the message:

    Error: The server dropped the connection (it may be too busy)

    I don't know why. I have changed computers and moved abroad but my Fetch settings remain the same. I have never had any problems with different version of Fetch on many different operating systems.

    I saw that someone else seemed to have this same problem and posted it on the list but there was not an answer. Jim Matthews asked for the contents of the Fetch Transcripts from the window menu. Here are mine:

    Fetch 4.0.2 System 0x1042 Serial FETCHED001-K056-Q835 TR
    Connecting to port 21 (18/9/05 16:22:14)
    Connecting to port 21 (18/9/05 16:22:33)
    Connecting to port 21 (18/9/05 16:22:43)
    Connecting to port 21 (18/9/05 16:22:57)
    Connecting to port 21 (18/9/05 16:24:46)
    Connecting to port 21 (18/9/05 16:25:21)
    Connecting to port 21 (18/9/05 16:26:43)
    Connecting to port 21 (18/9/05 16:31:44)
    Connecting to port 21 (18/9/05 16:44:57)

    Any help you can give me would be very much appreciated.

    Posted 18 years ago #

  • davedit Member

    This usually means that the maximum number of logins allowed on the server are already taken up. Maybe try again later when the server might not be so busy?

    Posted 18 years ago #

  • mac Member

    Thanks for your suggestion but I doubt that that is the problem. I know the server and who has access. I've never had this reply and I connect to that server a lot. Moreover, I've tried at different times during the day. The problem just started when I started using this new machine and from abroad.

    Posted 18 years ago #

  • metro Member

    Strange. I have been getting the same error.

    My friend recently added a firewall to his server and I can't get past it with fetch 4.0.3 (Mac OS X 10.4.2).

    I also tried to add the port number (21) in the "Non-Standard Port Number:" field. Same error as before.

    However when I go through the command line I can access the server just fine.

    What the heck is FETCH doing?

    Posted 18 years ago #

  • Scott McGuire Administrator


    Try toggling the "Use passive mode transfers (PASV)" checkbox in the Firewall section of the Fetch preferences. If it's on, turn it off; if it's off, turn it on.

    Let us know if that does not help. Thanks,

    Scott McGuire
    Fetch Softworks

    Posted 18 years ago #


  • Or nickname, if you prefer.
  • This will be kept confidential.
  • This is to ensure that you’re a person, not a spambot.