Your best friend for file transfer.

Fetch application logoFetch

Fetch 4.01 unable to access shortcuts in OS 10.1 (6 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 22 years ago by bbrisco
  • Latest reply 22 years ago from Jim Matthews
  • bbrisco Member

    Yesterday I installed OS 10.1, tried to use Fetch 4.0 which I had been using under OS 10.x and discovered it didn't work. Of course I went to right away, read about the update and downloaded Fetch 4.01. But when I tried to use 4.01 it acted strangely: I selected a shortcut, the Fetch window opened, the FTP server clearly accepted the username and password, and Fetch displayed the message "Getting File List"... but then it stalled. This happens for the dozen or so shortcuts I have.

    I ran Fetch 3 under Classic mode is OS 10.1 and it worked fine. I'm baffled as to why 4.01 has this glitch. Any idea?

    Barry Lee Brisco

    Posted 22 years ago #

  • nickovs Member

    I was having the same problem after upgrading. It seems that setting the Passive mode option in the Firewall setting of the Preferences fixes the issue :-)

    I've no idea why Passive mode should be needed; it looks like a bug. I get the same problem connecting to a server on the same subnet so it's not a firewall issue.


    Posted 22 years ago #

  • dgelb Member

    Same problem here. thanks for the tip. checking the pasv mode in prefs seems to have fixed the problem.

    Posted 22 years ago #

  • brandonarbini Member

    Passive mode fixed the problem, thanks.

    Posted 22 years ago #

  • bbrisco Member

    Well, setting the Firewall to Passive Mode did indeed solve the problem I described in the first post in this thread. But strangely enough, this morning, after booting up my system and asking Fetch to access a server, the problem recurred. Fetch would login to the server but then get "stuck" displaying the file list. So I checked in Preferences for the Firewall setting, and Passive Mode was no longer selected. I didn't de-select it since first selecting it, and I did not make any other changes to the Preferences. It just changed itself. Very odd.


    Posted 22 years ago #

  • Jim Matthews Administrator

    The passive mode setting won't stick unless you either set it in the Internet panel of System Preferences or uncheck "Use Internet Config" in Fetch's Preferences dialog.


    Jim Matthews
    Fetch Softworks

    Posted 22 years ago #

Topic closed

This topic has been closed.