Your best friend for file transfer.

Fetch application logoFetch

File List Not Displayed (4 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 20 years ago by tjsnet
  • Latest reply 20 years ago from Jim Matthews
  • tjsnet Member

    When trying to connect to our Mac OS X 10.2.2 Server (Xserve), Fetch 4.0.2 fails to retrieve the file list. A successful connection is made to the FTP server, after clicking "ignore" on the error message warning the cleartext passsword is being sent to a server which supports security.

    After a few minutes, Fetch fails to display the list and displays the error message: "Server response: Can't open data connection.

    I have tried to toggle the "PASV" setting in the Firewall preferences, but no luck.

    The Mac OS X 10.2.2 server is running the built-in firewall. Ports 20 and 21 have been opened to allow all requests.

    I also tested connections to the server using other programs, i.e. Transmit from my OS X client, a Terminal session from my OS X client and WS_FTP95 from my Windows 2000 client and all programs could connect and display the file list.

    Am I missing a setting in Fetch 4.0.2 or on the Mac OS X 10.2.2 server?


    Posted 20 years ago #

  • tjsnet Member

    Downloaded and installed Fetch 4.0.3, but I'm sorry to say the same result occured. I hope it's just something I'm missing...

    Thanks again for working to fix the bugs and provide updates and support.

    Posted 20 years ago #

  • tjsnet Member

    I wrote too soon...

    I gave it one more shot and "toggled" the "PASV" setting (the current setting is unchecked) and it worked. I still receive the security warning when connecting to the server (the choice to select ignore or disconnect). When I click ignore at the error warning, I am able to connect to the server and the file list is displayed.

    Thanks for the 4.0.3 update and sorry for the repeated posting.

    Posted 20 years ago #

  • Jim Matthews Administrator

    No problem -- and thanks for the follow-up!

    Jim Matthews
    Fetch Softworks

    Posted 20 years ago #

Topic closed

This topic has been closed.