Your best friend for file transfer.

Fetch application logoFetch

problems since adding router (5 posts)

This is an archived topic. The information in it is likely to be out-of-date and no longer applicable to current versions of Fetch.
  • Started 23 years ago by inarizushi
  • Latest reply 23 years ago from Jim Matthews
  • inarizushi Member

    Fetch worked perfectly (well, close enough) until I installed DSL and added a router. Are there certain settings in Fetch that need to be changed when using a router? Thanks.

    Posted 23 years ago #

  • Jim Matthews Administrator

    It may be that you need to check the "Use passive mode transfers (PASV)" box in the Firewall section of Preferences.

    Posted 23 years ago #

  • cannon Member

    I am having the same sort of problem. It is actually quite weird, and I've consulted A LOT of different sources to try and resolve this problem, but to no avail. I have no problems at all when I use fetch with my modem dial-up or even when I hook my DSL modem directly to my iMac. The problem starts when I add a basic 4-port hub in between the modem and my computer. I can download files with fetch and switch directories with no problem at all, but I can't upload at all. It tries to run, and in some cases, it appears that it is done, but a 0.0K file shows up when the screen is refreshed. The fact that I can switch directories would lead me to believe that some information is getting upstream (I also have no problems surfing the web and emailing files of any size), but it seems like it is a single type of data that my connection has problems with.

    If I let fetch just keep grinding away at an upload, it eventually fires back an alert box that says the following:

    "Server Response: Data Connection: Bad File Description"

    I just downloaded the new version of Fetch, and I've been playing with it for a while, with no good results. Any suggestions?? I've been fighting this problem since I got my DSL modem in October, and I have, for the most part, given up on it. Any kind of solution that helps me out (especially one that involves mixing up some Open Transport settings) would be greatly appreciated....and there are a lot of people that are dealing with the exact same problem that I could pass it on to.

    One last thing...we have a couple of PCs on our little DSL network, and they both work's pretty demoralizing....


    rev b iMac
    Mac OS9.0.4
    Paradyne DSL modem
    Netgear EN104TP Hub

    Posted 23 years ago #

  • inarizushi Member

    I tried checking the "Use passive mode transfers (PASV)" box, but still no change. What's really strange is that I am able to upload small text files, but the moment I try to upload anything larger, the dog keeps running and running to no avail, and now I am unable to access those pages on my Web site. I am given an error that says the "document contains no data." I need to update my Web site, and Fetch is the only way I know how to do it, so any help would be appreciated. Thanks!

    I'm using a LINKSYS four-port router with my 20th anniversary Mac.

    Posted 23 years ago #

  • Jim Matthews Administrator

    I would recommend that both of you (cannon and inarizushi) try uploading with a different FTP client, such as VicomSoft's. If you have the same problems you'll know that it's an issue with your hub, router or DSL line as opposed to your software.

    Jim Matthews
    Fetch Softworks

    Posted 23 years ago #

Topic closed

This topic has been closed.