Your best friend for file transfer.

Fetch application logoFetch
Fetch Icon Fetch Help > Windows > File List

The list of file and folders names in the middle of a Fetch transfer window is the file list. It works much like the Mac OS Finder's list view.

In the file list, clicking an item selects it. Many commands such as Get, Delete Item, Edit, etc. operate on the selected item. Holding down the Command key while clicking allows you to select multiple individual items, and holding down the Shift key while clicking selects a range of items. You can also select a filename by typing the first few letters of its name, or using the up and down arrow keys to step through the list.

Double-clicking an item prompts Fetch to either download the file or change to the selected folder. Pressing Command-Down arrow is equivalent to double-clicking. Command-double-click a folder to display its contents in a new transfer window.

Dragging files or folders from the Mac OS Finder to the file list will upload those items to the current folder displayed in the file list; if you drag them to a folder icon in the Fetch file list, they will be uploaded to that remote folder.

Dragging files or folders from the file list to the Mac OS Finder will download the items. Dragging items in the file list to a folder in the file list will move those items on the server. Dragging items from one file list to another file list will either move the items (if the file lists are for folders that are on the same server) or copy the items to the other server (if the file lists are for folders on different servers.)

You can rename files in the file list by clicking once to select an item, and then pressing the Return key. An edit box appears around the name. Type a new name or edit the existing name, and press Return again when you're done. For more information, see the renaming files and folders help topic.

The window title bar shows the name of the current folder, and then either the name of the shortcut matching this server or the server's hostname. Click the Path button in the toolbar or Command-click the window's title to display the complete hierarchy leading to the current folder. Choose a folder from the menu to make that the current folder and update the file list.

The Back button in the toolbar takes you back to the folder you were previously viewing. See the changing folders help topic for other ways to change the current folder and move between folders.

The file list can be sorted by name, file kind, file size, or last modification date. The current sort order is indicated by the highlighted column title. To change the sort order, click a different column title. Click a highlighted column title to reverse the sort order. The columns can be resized by clicking on the divider between the titles and dragging. You can also reorder the columns by clicking in the middle of a column heading and dragging it to the left or right.

You can filter the file list to show only files or folders whose names contain certain text with the Find command. Choose Edit > Find and enter a name or part of a name of a file in the Find field. You can unfliter the file list by clicking the clear button in the Find field, or choosing Edit > Hide Find Field. Note that the Find command only searches the names of items currently displayed in the file list; it does not search the contents of folders.

Fetch displays a small icon next to each name. Files have an icon appropriate for the kind of file they are; if Fetch cannot determine the kind of a file, a standard document icon is shown. Folders have the standard folder icon. If Fetch cannot determine whether an item is a file or folder, a combined folder/document icon is displayed. If the item is a UNIX symbolic link (a pointer to a file or folder in a different place), Fetch shows an alias badge on the icon.

The info bar just above the file list contains the following items, from left to right:

  • The Find field, if you've chosen Edit > Find.
  • The total number of items in the file list.
  • A date and time showing when the file list was last read from the server, if the file list was read from the cache, as explained below.
  • The Refresh button, which reloads a fresh file list from the server. If you don't see a file listed in the file list after uploading it, click the Refresh button.
  • For secure connections (SFTP, FTP with TLS/SSL, and Kerberos with encryption), Fetch displays a locked padlock icon. An unlocked padlock icon indicates your password was sent securely, but encryption is not being used to secure your transfers. No padlock icon is displayed if the connection is not secure at all. For more information, see the padlock icon and security help topics.

Fetch can optionally reuse file lists rather then downloading them again when there is reason to believe that the cached (stored) list is up-to-date. Using the cache will make file lists load faster, but on rare occasions newly uploaded files may not appear in the file list. File list caching is disabled by default; it can be enabled by unchecking the Ignore file list cache checkbox in the Miscellaneous Preferences pane. When Fetch uses a stored file list, it shows the date and time when the list was originally retrieved on the right just above the file list. If the stored list seems to be out of date, you can reload a fresh list from the server by choosing View > Refresh or clicking the Refresh button. (The technical details: a file list is cached for 5% of the age of its newest item. For example, if newest item's modification time is 20 days ago, the list will be read from the cache for the following day.) Fetch stores file lists in the "Fetch Cache" file, located in the com.fetchsoftworks.Fetch folder in your Caches folder.

Useful keyboard shortcuts for the file list: Pressing the Down arrow key while holding down the Command key makes the selected folder the current folder. Pressing Command-Up arrow takes you to the parent folder (go up one level). You can also use the Home, End, Page Up, and Page Down keys to scroll the file list.

You can also perform common transfer window actions with the file list contextual menu. Control-click an item in the file list to display the contextual menu. The file list contextual menu includes two special commands not available elsewhere — the Duplicate command for duplicating files on the server, and the Clone Window command. Both open another connection and transfer window to the same server of the current transfer window.

It's also possible to make a new copy of an item in one folder by Option-dragging the item to another folder icon in the file list. The copy cursor indicates that the item will be copied rather than simply moved. Like the Duplicate command, Option-dragging an item to make a copy of it will open a second connection to the server in a new transfer window.

Another way to copy files and folders from one folder to another on the same server, or from one server to another, is to use the Copy and Paste commands. See the copying files using copy and paste help topic for more information.