Your best friend for file transfer.

Fetch application logoFetch
Fetch Icon Fetch Help > What's New > Fetch 5.7 for Fetch 5 Users

The interface and behavior of Fetch 5.7 are similar to previous versions of Fetch 5.

The major changes in Fetch 5.7 are a find field for filtering file lists, display of overall transfer progress, preservation of the modification dates of uploaded files, and support for syncing shortcuts between computers.

The major changes in Fetch 5.6 were automatic resume of stalled or failed downloads, and improvements to the automatic resuming of uploads.

The major changes in Fetch 5.5 were the ability to edit any kind of file using any application and the changes will automatically be saved back to the server, automatic resume of stalled or failed uploads, and Quick Look support for previewing files on servers.

The major changes in Fetch 5.3 were improved compatibility and appearance on Mac OS X 10.5 Leopard, support for new Mac OS X 10.5 features and technologies, and a preference to turn off automatic decoding for all file types.

The major changes in Fetch 5.2 were the new WebView feature, support for FTP with TLS/SSL (FTPS), droplet shortcuts, and a rewritten FTP networking layer.

The major changes in Fetch 5.1 were that Fetch became Universal (built to work on both Intel-based and PowerPC-based Macintosh computers), and the addition of Automator actions and built-in StuffIt support.

Here's a quick guide to the changes to existing features in Fetch 5.7. This is just an overview; for a detailed list of all the changes in Fetch 5.7, see the Fetch 5.7 Release Notes. If you are upgrading from Fetch 4, see the Fetch 5.7 for Fetch 4 Users topic instead.

Changes from 5.6 to 5.7

New Feature: Shortcut Syncing

Fetch Shortcuts can now be synchronized between multiple computers using Dropbox or a shared file server. Shortcuts created on one computer will automatically appear on the others, making it easy to keep all your computers up to date with all of your shortcuts.

New Feature: Find Field

The Find command now creates a find field in transfer windows. Typing into the find field filters the file list, so that it only displays the files that match the typed text. This makes it very easy to focus on files that share a common name extension, for example.

Transfer Progress

Fetch now reports transfer progress — the amount of data transfered so far and yet to be transfered, and the estimated time remaining — for the overall transfer, rather than for each individual file. This makes it much easier to see how much of a multi-file transfer has been completed, and when the entire transfer will be finished.

Put and Uploading

Fetch will now preserve the modification date of uploaded files. This improvement requires server support that is present on most, but not all, FTP and SFTP servers.

System Requirements

Fetch 5.7 now requires an Intel Mac running OS X 10.5 or later. Mac OS X 10.4 and PowerPC Macs are no longer supported.

Changes from 5.5 to 5.6

Get and Download

Fetch now automatically tries to resume downloads when the transfer stalls or unexpectedly stops due to a network or server error. The manual resume download feature remains available, but you should rarely need it.

Put and Uploading

Fetch's automatic resume upload feature now resumes uploads and avoids unnecessary retries in more circumstances.

Droplet Shortcuts

Droplet shortcuts now queue uploads. If an upload to the server referred to by the droplet shortcut is already in progress when you drag items to the droplet shortcut, they will be uploaded after the current upload finishes, instead of opening a new transfer window.

System Requirements

Fetch 5.6 now requires Mac OS X 10.4 or later. Mac OS X 10.3.9 is no longer supported.

Changes from 5.3 to 5.5

New Feature: Edit with Anything

The Fetch Edit command now lets you edit any kind of file using any application, and the changes will be saved back to the server automatically. This means the Edit command now works with any HTML editor (including Dreamweaver and GoLive), any image editor (including Photoshop), word processors (such as Microsoft Word), and any text editor (not just the limited set previously supported).

The default editor for a kind of file is usually the same as the application that would normally open that kind of file. If Fetch's default choice is not the application you would like to use for editing, hold down the Option key when choosing the Edit menu item or clicking the Edit button, and the command will become Edit With. Fetch will ask you to choose a different application to use for editing and whether you want Fetch to remember this choice for the future or not.

You can also choose a different editor temporarily with the Edit With submenu in the Remote menu or the contextual menus.

The Edit text files with and Edit image files with preferences have been removed. Instead, you can change the editor application for a specific kind of file using the Transfer Options pane of the info window.

New Feature: Quick Look

On Mac OS X 10.5 and later, Quick Look has replaced the View command and toolbar button for previewing files without leaving Fetch. The Quick Look command can display many more kinds of files than the View command could — it can display text files, images, sounds, movies, PDFs, Microsoft Word and Excel files, and more. You can still view any file as a plain text file using View as Text.

Put and Uploading

Fetch now automatically tries to resume uploads when the transfer stalls or unexpectedly stops due to a network or server error. The manual resume upload feature remains available, but you should rarely need it.

When the Automatic upload format encounters a file that includes significant special Macintosh information that needs to be preserved (the file has a significant resource fork), Fetch will now upload that file using the Zip Archive format instead of StuffIt X Format.

The If a file exists: Pick a different name option in the Put dialog is no longer available for FTP uploads, because many FTP servers responded poorly to that option. It remains available for SFTP uploads.

Get Info and Info Window

The Get Info command no longer automatically calculates size of folders, making it much quicker to open info windows, such as when you just need to set permissions. You can calculate the size of folders by clicking the new Calculate button in the info window. The Get Quick Info command has been removed since it is no longer necessary.

Transfer Window

The display of information in the transfer window title bar has changed in two ways. First, the title bar shows the shortcut name instead of the server's hostname when there is a matching shortcut for that server. Second, the folder name is now listed first, followed by the shortcut name or hostname.

On laptops whose trackpads support gestures, in the transfer window you can now swipe left to go back to previously viewed folder, swipe up to go to the parent folder, and swipe down to open the selected folder.

The transfer window now remembers your last column sorting choice, so if you prefer that your file lists always start sorted by modification date, they will be.

You can now type Command-O to open the selected folder in the file list.

Recent Connections

The Recent Connections menu now shows the shortcut name instead of the hostname when there's a matching shortcut.

Droplet Shortcuts

There are two new options when you create a droplet shortcut — you can set the droplet shortcut to always upload files in a specific upload format, and choose to have Fetch quit after an upload started by the droplet shortcut completes.

Changes from 5.2 to 5.3

New Features

There is now a preference to turn off automatic decoding for all file types. Choose Fetch > Preferences, click the Download tab, and check or uncheck the Allow automatic decoding of downloaded files checkbox. When the Allow automatic decoding of downloaded files checkbox is checked, you can continue to disable decoding for only certain kinds of files using the Automatically decode files like this checkbox in the Transfer Options section of the info window.

You can now upload files and folders using Copy and Paste, or use Copy and Paste to copy files and folders from one folder to another on the same server, or from one server to another.

Mac OS X 10.5 Leopard Support

The transfer window and toolbar buttons have an updated look for Mac OS X 10.5.

The Fetch application is digital signed, which among other things, will reduce or eliminate various keychain alerts.

Fetch supports the Mac OS X 10.5 application-specific firewall.

New Connection Dialog

You can now enter a path after the hostname in the Hostname field, e.g. ftp.fetchsoftworks.com/example, and be taken to the folder specified by that path.

On Mac OS X 10.5 and later, the FTP with KClient choice in the Connect using pop-up menu is disabled, because KClient (Kerberos v4) is no longer supported on Mac OS X 10.5.

Preferences

The Allow automatic decoding of downloaded files checkbox has been added to the Download Preferences pane.

On Mac OS X 10.5 and later, the default download location as specified by the Save downloaded files to preference is the new Downloads folder. On Mac OS X 10.4, the default download location remains the Desktop.

Automator

On Mac OS 10.5 and later, Automator lists the Fetch actions under the Internet category.

Changes from 5.1 to 5.2

New Features

WebView lets you easily view files in your web browser and copy web addresses while in Fetch. Once you've created a WebView entry that sets up a correspondence between the Fetch address of items on a file server and the web address of the webpage they are part of, you can easily view changes to your site in a web browser by clicking the WebView button in Fetch. You can also use the Copy Web Address command to copy a web address link (URL) of the items selected in Fetch. See the WebView help topic for more information.

Fetch now supports connecting using FTP with TLS/SSL (FTPS) — choose FTP with TLS/SSL from the Connect using pop-up menu. See the FTP with TLS/SSL help topic for more information. If Fetch is your default FTP helper, it will become your default FTP with TLS/SSL helper automatically.

You can use the new Save Droplet Shortcut command to create a droplet shortcut to which you can drag and drop files to in the Finder or Dock to upload those files to a specific server.

The FTP networking layer has been rewritten for improved compatibility and performance.

New Connection Dialog

The Connect using pop-up menu now lists FTP with TLS/SSL (FTPS) as one of the choices. Shortcuts and recent connections also support FTP with TLS/SSL.

Transfer Window and Toolbar

The Refresh button is no longer in the transfer window toolbar; it is now a smaller button () located on right-hand side of the info bar just above the file list.

A WebView button has been added to the toolbar.

You may lose some toolbar customizations when upgrading from an earlier version of Fetch to Fetch 5.2, due to the changes in the toolbar buttons. We apologize for the inconvenience.

Menus

The Save Droplet Shortcut command is available in the File menu when you select no files or a single folder in the file list.

If you hold down the Option key when choosing Get, the command will change to Get As, and Fetch will prompt you to choose a folder on your Macintosh to which it should download the selected files and folders. This lets you temporarily override the download folder specified by the Save downloaded files to preference in the Download Preferences pane.

The Copy URL command has become Copy Fetch Address and Copy Web Address.

The Copy Plain and Copy Plain URL commands have been removed; all URLs are now copied without angle brackets.

Preferences

The Preferences window has a new pane, WebView, for viewing and modifying your WebView entries.

The Contact server during long transfers preference has been removed from the Obscure pane, because it is no longer necessary as a result of the rewritten FTP networking layer.

Changes from 5 to 5.1

New Connection Dialog

The New Connection dialog is now modeless — you can use other Fetch windows and most Fetch menu commands while the New Connection dialog is open.

The Recent Connections pop-up menu now has a Clear Menu command at the bottom of the menu for removing all the entries from the menu.

Shortcuts and Passwords

Fetch 5.1 and later store shortcuts in a different format than previous versions of Fetch, so while you can continue to use Fetch 5.1 and an earlier version of Fetch on the same Macintosh, you will not see changes you make to the Fetch 5.1 shortcuts in the previous versions of Fetch, and vice versa. The first time you open Fetch 5.1, it will automatically read and upgrade your shortcuts from your previous version of Fetch.

While previous versions of Fetch allowed you to save a shortcut password in the shortcut itself, in Fetch 5.1 all shortcut passwords are saved in your keychain. When you upgrade to Fetch 5.1, your shortcut passwords will be automatically moved to the keychain if they are not stored there already.

The file where Fetch stores your shortcuts has changed. They are now stored in a file named "com.fetchsoftworks.Fetch.Shortcuts.plist" in the Preferences folder in the Library folder in your home folder. Fetch 5 stored shortcuts in a file named "Fetch Shortcuts" in that same location. (After you upgrade, you will have both files — the older file is saved both as a backup, and in case you want to continue to use Fetch 5.)

If you have created separate shortcut list documents, they will be upgraded to the new format the first time you open them with Fetch 5.1. After they have been upgraded, you cannot use them with earlier versions of Fetch anymore. Fetch does not make a backup during the upgrade, so if you think you may want to continue to use them with an older version of Fetch, please make a backup of your shortcut list documents before opening them in Fetch 5.1.

StuffIt and Archive Support

The StuffIt Engine is now built into the Fetch application. A separate installation or updating of StuffIt is no longer required to use StuffIt and Archive support in Fetch.

In Fetch 5.1 and later, the Zip Archive format now preserves Macintosh information. That is, like the Compress (Create Archive) command in the Finder, Fetch's creates .zip files that preserve both data and resource forks, long file names, and other Macintosh Finder information.

If a Windows user downloads a Zip archive created by Fetch, it may contain extra data that cannot be interpreted on Windows. Windows users can easily ignore this extra Macintosh-only information. There is no way to create a Zip archive without the extra Macintosh information when uploading in Fetch, although the extra information is usually only added when necessary.

Fetch's automatic decoding will now properly decode Zip archives that contain Macintosh information.

Automator

Also new to Fetch 5.1 are a number of actions for Mac OS X's Automator, allowing you to create simple workflows that can automate a variety of Fetch tasks. The actions are: Delete Fetch Items, Download Fetch Items, Filter Fetch Items, Generate Fetch Item Report, Get Fetch Folder Contents, Get Selected Fetch Items, Get Specified Fetch Items, Move Fetch Items, Rename Fetch Items, Set Fetch Item Permissions, and Upload Files. See the introduction to using Automator with Fetch, Automator actions and more examples of using Automator with Fetch help topics for more information.

AppleScript

The AppleScript dictionary in Fetch 5.1 has a variety of additions and changes in order to support new features and make Fetch even more scriptable than before. See the AppleScript changes help topic for more information.